Issues with input PreviousNext
Mplus Discussion > Confirmatory Factor Analysis >
 Ben Biermeier-Hanson posted on Monday, June 02, 2014 - 11:00 am

I'm running Mplus 6.11 for mac, which means I am running input files from the text editor into the terminal.

I have been able to run the examples included just fine. I am not, however, able to read in my own input files (I am using syntax that has worked on other people's computer's so there doesn't appear to be a syntax issue). I am using the default directory that has worked with the examples. I drag and drop the input file into the terminal (it has the .inp ending) though that doesn't appear to show up in the error message. I get the following error message - any help would be appreciated.

(Err#: 29)
Error opening input file: /Users/Ben/Dropbox/Methods\ \&\ Statistics/Mplus/Mptext1\ -\ affective\
 Linda K. Muthen posted on Monday, June 02, 2014 - 5:30 pm
What is the name of the input file that you are using? If the examples have worked on this same directory, then your input should work without any problems. Error 29 reports that the file is not found.
 Ben Biermeier-Hanson posted on Tuesday, June 03, 2014 - 5:34 am
I'm using a file called metric invariance.inp. I did rename this manually, as otherwise it would be a text file. I have added it to the example directory and it hasn't worked.

As an added bit of detail I am editing in text edit on my mac but saving as a plain text file (.txt) then renaming, as mentioned above. The file runs on other (windows) computers so it does not seem to be a syntax issue and I have used the .inp files generated by mplus in the terminal as well and have received the same error, so the manual renaming does not seem to be the issue.

Is there anything else here I may be missing that would help me solve this problem?
 Johanna Folk posted on Sunday, January 15, 2017 - 8:45 am
I am having a similar problem. The datafile definitely exists, but I am receiving the error 29 as well. I have been accessing this same datafile to run analyses for the past hour, using the same data command, but all of a sudden it is no longer working.
 Linda K. Muthen posted on Sunday, January 15, 2017 - 9:51 am
Please send the files and your license number to
Back to top
Add Your Message Here
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Options: Enable HTML code in message
Automatically activate URLs in message