False claim: "Variance of zero" PreviousNext
Mplus Discussion > Confirmatory Factor Analysis >
 Tanja Gabriele Baudson posted on Friday, March 30, 2012 - 9:00 am

I am trying to run a CFA with a set of variables; however, MPlus refuses to analyze the data with the error message that one or more have a variance of zero. I checked all the files, and this simply is not true.

I tried to delete some (but still not all) variables from the original SPSS file which were not urgently needed before exporting the .dat file, with the success that some of the variables which were previously ascribed a variance of zero now were not flagged as problematic any more. How can this be? Once MPlus (falsely) identifies a variance of zero, once it does not? This is really annoying, as I am somewhat unsure whether I can trust the analyses (if only they worked ...) at all. Where does this error come from?

 Linda K. Muthen posted on Friday, March 30, 2012 - 9:33 am
It sounds like you are reading the data incorrectly. Please send the input, data, output and your license number to support@statmodel.com.
Back to top
Add Your Message Here
Username: Posting Information:
This is a private posting area. Only registered users and moderators may post messages here.
Options: Enable HTML code in message
Automatically activate URLs in message